Softwarová konzola pro monitorování počítače zaměstnanců

Přidání vzdálených počítačů do konzoly

Abyste mohli sledovat vzdálené počítače, musíte je nejprve přidat do konzole. Počítače můžete přidat čtyřmi způsoby:

Pomocí nabídky File přidejte počítače:

Možnosti sledování

Přidat počítače ručně

V nabídce File vyberte možnost „Přidat počítač...“:

Dialogové okno má dvě karty:

  • Základní možnosti
  • Pokročilé možnosti

Basic Options

Přidejte počítač, který chcete sledovat

Parametry:

Remote computer (host or IP):

Zadejte síťový název hostitele nebo IP vzdáleného počítače. Při použití DHCP v místní síti musíte zadat název počítače.

Nickname:

Zadejte název, který se má zobrazovat, aby bylo možné snadno identifikovat vzdálený počítač.

Agent’ password:

Do tohoto pole zadejte stejné heslo, jaké jste použili při instalaci agenta.

Connection Type:

Přímé připojení

Používá přímé spojení TCP/IP mezi administrátorskou konzolí a agenty. Konzole funguje jako klient a agent jako server. Přímé připojení funguje, např. pokud jsou všechny počítače ve stejné síti nebo je mezi podsítěmi nakonfigurováno správné směrování. Použitý port (výchozí TCP 4495) musí být povolen pro komunikaci.

Obrácené připojení

Používá přímé spojení TCP/IP mezi administrátorskou konzolí a agenty. Konzole funguje jako server a agent jako klient. Reverzní připojení funguje, například pokud jsou všechny počítače ve stejné síti nebo je mezi podsítěmi nakonfigurováno správné směrování. V konzole musíte povolit "Console Reverse Connection Server". Musíte zadat název hostitele konzoly nebo IP, ke kterému se agent připojí. Použitý port (výchozí TCP 444) musí být povolen pro komunikaci.

Cloudové připojení

Můžete se rozhodnout zpřístupnit tento počítač také prostřednictvím cloudového připojení výběrem možnosti „Použít cloudové připojení“, které vám umožní sledovat počítač přes internet.

Cloudová licence je založena na předplatném. Přečtěte si další informace o instalaci do cloudu.

 

Advanced Options

Nakonfigurujte počítač, který chcete sledovat

Parametry:

TCP Port:

Do tohoto pole zadejte stejný port jako při instalaci agenta. Výchozí port je 4495.

Connection security:

Zvolte Auto (nejprve se zkouší TLS; koncové šifrování se použije jako náhrada pouze tehdy, pokud agent vůbec neodpoví pomocí TLS), nebo nastavte pevně End-to-end encryption či TLS tak, aby volba odpovídala nastavení agenta. Při použití TLS si konzole při prvním připojení uloží („připne“) otisk certifikátu a kontroluje jej při každém dalším připojení. Tlačítko Forget uložený otisk vymaže, například po přeinstalování agenta s novým certifikátem. Pokud je konzole nastavena tak, aby nové certifikáty čekaly na schválení místo automatického důvěřování (viz Configuration / General), zobrazí se zde i certifikát čekající na schválení s tlačítkem Trust... pro kontrolu a potvrzení jeho otisku.

Connect automatically:

Zaškrtněte toto políčko, pokud má být vzdálený počítač automaticky připojen při spuštění „Net Monitor for Employees Professional Console“.

Monitor :

Vyberte, který monitor se zobrazí jako miniatura.

Multisession - terminal (TS, RDP) options :

Vyberte, zda je váš počítač RDP, server TS. To vám umožní vidět všechny vzdálené relace.

Account filter

Otevřete kartu Account filter a vyberte, které uživatelské účty Windows na tomto počítači budou monitorovány.

Zvolte "Monitor all accounts except selected", chcete-li sledovat všechny účty kromě těch, které uvádíte (např. vyloučit „Administrátora“), nebo "Monitor only selected accounts", chcete-li sledovat pouze účty, které uvádíte. Zadejte název účtu a kliknutím na Add jej přidejte do seznamu, vyberte záznam a kliknutím na Remove jej odeberte.

Filtr se aplikuje na relaci, takže také funguje správně, když je počítač terminálovým serverem (TS, RDP) s několika přihlášenými uživateli současně – účet každé relace je kontrolován proti filtru nezávisle a nemonitorované účty se v konzole jednoduše nezobrazují.

Přidat počítače z cloudu

Pokud jste agenta nainstalovali na vzdálené počítače pomocí typu Cloud Connection, můžete nyní tyto počítače přidat do konzole.

Ujistěte se, že jste si vytvořili Cloud account. Cloudový účet lze vytvořit během instalace agenta nebo pomocí nabídky " Cloud / Create cloud account...".

Konfigurace Cloud Monitoring

Klikněte sem a přečtěte si další informace o monitorování pomocí cloudového připojení.

Pokud jste již vytvořili Cloud account, můžete tyto přihlašovací údaje ke cloudovému účtu zadat do konzole pomocí nabídky „ Cloud / Configure cloud connection“:

Konfigurace sledování prostřednictvím cloudu

Potom můžete pomocí nabídky „ Cloud / Add computers from Cloud“ přidat počítače, které již byly do cloudu přidány.

Při přidávání počítačů z cloudu je třeba zadat heslo agenta (heslo, které bylo zadáno při instalaci agenta na vzdáleném počítači)

Vyhledat v síti nainstalované agenty

Prohledat počítače v síti

Pokud jste již nainstalovali agenty na vzdálené počítače, můžete prohledat síť a přidat je automaticky. Skenování nevyžaduje výběr typu připojení předem – pro každou adresu nejprve zkouší TLS a vrátí se k end-to-end šifrování pouze v případě, že adresa aktivně odpovídá, ale odmítne TLS, takže agenti používající oba režimy jsou nalezeni bez další konfigurace.

Vyberte síťový adaptér a rozsah IPv4, zadejte heslo agenta a port a klikněte na Scan. Kliknutím na Stop zastavíte aktivní kontrolu.

Časté dotazy: Jak nastavím výchozí síťový adaptér pro skenování?

Otevřít File / Configuration.... Na kartě General vyberte požadovaný adaptér v části Default network adapter a klikněte na OK. Každý nový dialog Scan network for computers... vybere tento adaptér. Pokud není k dispozici, je vybrán první aktivní adaptér. Pro aktuální kontrolu můžete vybrat jiný adaptér, aniž byste změnili nakonfigurované výchozí nastavení.

Výsledky zobrazují název hostitele, IP adresu a stav hesla. Když je heslo správné, OS zobrazí nahlášený operační systém se svou ikonou a Agent version zobrazí verzi nahlášeného agenta. Tyto podrobnosti se zobrazí pouze tehdy, jsou-li k dispozici; neexistuje žádný samostatný sloupec verze OS ani zástupný symbol neznámé hodnoty.

Show only computers not yet added není ve výchozím nastavení zaškrtnuto, takže se zobrazí všechny nalezené počítače. Zaškrtnutím tohoto políčka skryjete počítače, jejichž název hostitele nebo IP adresa již v konzole je. Chcete-li je znovu zobrazit, vymažte jej.

Pomocí Select all nebo Unselect all změňte zaškrtávací políčka pro aktuálně viditelné výsledky. Individuální volby jsou zachovány, když se objeví další výsledky a když se změní filtr. Add přidá pouze zaškrtnuté, viditelné počítače. Sloupce se automaticky vejdou na nejširší položku.

V Properties počítače je ikona operačního systému umístěna bezprostředně vlevo od nahlášeného názvu operačního systému; verze agenta se zobrazí, je-li k dispozici. Pokud starší agent nahlásí Windows 10 na počítači Windows 11, aktualizujte agenta a znovu se připojte nebo naskenujte znovu.

Přidat skupinu LAN počítačů

Monitorování počítačů na LAN

Do svého LAN můžete automaticky přidávat počítače. Agenta lze nainstalovat vzdáleně, pokud to vaše LAN umožňuje (např. pokud jste administrátor NT DOMAIN).

Zaškrtávací políčko Show only computers not yet added je k dispozici také v Add group of LAN computers. Ve výchozím nastavení není zaškrtnuto; zaškrtnutím skryjete názvy počítačů již přidané do konzole.

Seznam vzdálených počítačů

seznam

Remote Computers List zobrazuje všechny přidané počítače. Ikona počítače zobrazuje stav vzdáleného počítače.

Několik systémových příkazů je snadno přístupných pomocí Object Menu, kterou lze vyvolat kliknutím pravým tlačítkem myši.

Počítače lze organizovat do skupin – použijte " Add computer group..." z nabídky File.

Klikněte pravým tlačítkem myši na skupinu počítačů a z nabídky objektů vyberte "Filter by this group on Remote Screens", čímž okamžitě přefiltrujete kartu Remote Screens na tuto skupinu – jedná se o stejný filtr, který můžete nastavit také pomocí rozevíracího seznamu skupinového filtru na kartě Remote Screens.

Ve výchozím nastavení se při spuštění konzoly rozbalí všechny skupiny počítačů. Toto můžete změnit pomocí " Configuration..." z nabídky File, karta General, zrušením zaškrtnutí políčka " Expand groups when console starts".

Na stejné kartě General je ve výchozím nastavení zaškrtnuto "Automatically trust a computer's certificate the first time it connects over TLS. Zrušte zaškrtnutí, chcete-li, aby byl certifikát nového počítače schválen ke schválení, místo abyste mu automaticky důvěřovali – viz Connection security výše.

Import a export počítačů (CSV, oddělený tabulátory, Excel)

Počítače a skupiny lze hromadně exportovat do souboru CSV, text oddělený tabulátory nebo Microsoft Excel (.xlsx) a importovat zpět. Zvolte "Export Computers to File..." a "Import Computers from File..." z nabídky File nebo klikněte pravým tlačítkem myši na skupinu počítačů (nebo na prázdnou oblast seznamu, abyste zahrnuli vše) a vyberte stejné příkazy z nabídky Object Menu. Soubory se čtou a zapisují jako UTF-8.

Při exportu vyberte typ souboru přímo v dialogu Save: CSV (Comma delimited), CSV (Semicolon delimited), Tab Delimited Text nebo Microsoft Excel. Při importu se oddělovač souboru CSV nebo souboru odděleného tabulátory rozpozná automaticky.

Exportovaný soubor používá pořadí sloupců níže. Při importu lze změnit pořadí sloupců, pokud řádek záhlaví zachová stejné názvy sloupců; Nerozpoznané sloupce jsou ignorovány a sloupec ponechaný prázdný používá výchozí nastavení uvedené níže – je vyžadován pouze host:

SloupecPopisVýchozí, když je prázdný
skupinaSkupinová cesta počítače, např. /Laboratoř1/MístnostA. Chybějící skupiny se při importu vytvoří automaticky.Kořen (/)
jménoZobrazované jméno (přezdívka) zobrazené v konzole.Vrátí se zpět na hostitele
hostitelIP adresa nebo název hostitele vzdáleného počítače.Povinné – řádek je přeskočen, pokud je prázdný
portPort pro připojení agenta.Výchozí port agenta
hesloHeslo pro připojení agenta.Viz poznámka níže – nikdy neexportováno
typ_připojeníPřímé, Reverzní, Cloudové nebo kombinace oddělené čárkami.Přímé
auto_connectAno nebo Ne – zda se konzole připojí automaticky při spuštění.Ano
více relacíAutomaticky, Single nebo Multi.Automaticky
hwidID hardwaru registrace agenta v cloudu.Vyžadováno pro automatické připojení položky Cloud; viz poznámka níže

Sloupec password zůstává při exportu vždy prázdný – hesla se do souboru nikdy nezapisují. Při importu lze společné heslo zadat jednou a použije se pro každý řádek, jehož sloupec hesla je prázdný; řádek s vlastní hodnotou hesla místo toho použije tuto hodnotu.

U počítače, jehož connection_type zahrnuje Cloud, by mělo být uvedeno také hwid – identifikuje registraci agenta v cloudu. Pokud pole zůstane prázdné, otevřete Vlastnosti importovaného počítače a znovu povolte Use Cloud connection, abyste vybrali odpovídající počítač ze svého cloudového účtu a znovu jej připojte.

Jste připraveni začít sledovat své zaměstnance?

Kupte si tuto aplikaci nyní. Svého rozhodnutí nikdy nebudete litovat.

Koupit nyní