従業員コンピュータ監視ソフトウェア コンソール

コンソールでのリモート コンピュータの追加

リモート コンピュータを監視できるようにするには、まずリモート コンピュータをコンソールに追加する必要があります。コンピュータを追加するには、次の 4 つの方法があります。

File メニューを使用してコンピュータを追加します。

監視オプション

コンピュータを手動で追加する

File メニューから [コンピュータの追加...] を選択します。

ダイアログには 2 つのタブがあります:

  • 基本オプション
  • 詳細オプション

Basic Options

監視するコンピュータを追加します

パラメータ:

Remote computer (host or IP):

リモート コンピュータのネットワーク ホスト名または IP を入力します。ローカル ネットワークで DHCP を使用する場合は、コンピュータ名を入力する必要があります。

Nickname:

リモート コンピュータを簡単に識別できるように表示する名前を入力します。

Agent’ password:

このフィールドには、エージェントのインストール時に使用したものと同じパスワードを入力します。

Connection Type:

直接接続

管理コンソールとエージェントの間で直接 TCP/IP 接続を使用します。コンソールはクライアントとして機能し、エージェントはサーバーとして機能します。直接接続は、たとえば、すべてのコンピュータが同じネットワーク上にある場合、またはサブネットワーク間で適切なルーティングが構成されている場合に機能します。使用するポート (デフォルトは TCP 4495) が通信用に有効になっている必要があります。

逆接続

管理コンソールとエージェントの間で直接 TCP/IP 接続を使用します。コンソールはサーバーのように機能し、エージェントはクライアントとして機能します。逆接続は、たとえば、すべてのコンピュータが同じネットワーク上にある場合、またはサブネットワーク間で適切なルーティングが構成されている場合に機能します。コンソールで「コンソール逆接続サーバー」を有効にする必要があります。エージェントが接続するコンソールのホスト名または IP を指定する必要があります。使用するポート (デフォルトは TCP 444) が通信用に有効になっている必要があります。

クラウド接続

[クラウド接続を使用する] を選択すると、クラウド接続経由でもこのコンピューターにアクセスできるようにすることができます。これにより、インターネット経由でコンピューターを監視できるようになります。

クラウド ライセンスはサブスクリプション ベースです。 クラウドへのインストールについて詳しくは、こちらをご覧ください。

 

Advanced Options

監視するコンピュータを設定します

パラメータ:

TCP Port:

このフィールドには、エージェントのインストール時に使用したのと同じポートを入力します。デフォルトのポートは 4495 です。

Connection security:

Auto (最初に TLS を試行し、エージェントが TLS で応答しない場合にのみエンドツーエンド暗号化にフォールバックします) を選択するか、End-to-end encryption を強制します。 TLS をエージェント独自の設定に一致させます。 TLS が使用されている場合、コンソールは最初の接続時に証明書のフィンガープリントを記憶 (「ピン留め」) し、その後の接続のたびにそれをチェックします。 Forget ボタンは、固定されたフィンガープリントをクリアします (たとえば、新しい証明書を使用してエージェントを再インストールした後)。新しい証明書を自動的に信頼するのではなく、承認のために保持するようにコンソールが設定されている場合 (Configuration / Generalを参照)、ここにも承認待ちの証明書が表示され、フィンガープリントを確認して確認するための Trust... ボタンが表示されます。

Connect automatically:

「Net Monitor for Employees Professional Console」の起動時にリモート コンピュータが自動的に接続されるようにする場合は、このチェックボックスをオンにします。

Monitor :

サムネイルとして表示するモニターを選択します。

Multisession - terminal (TS, RDP) options :

コンピュータが RDP、TS サーバーであるかどうかを選択します。これにより、すべてのリモート セッションを表示できるようになります。

Account filter

Account filter タブを開いて、このコンピュータ上のどの Windows ユーザー アカウントを監視するかを選択します。

"Monitor all accounts except selected" を選択して、リストしたアカウントを除くすべてのアカウントを監視するか(「管理者」を除外するなど)、リストしたアカウントのみを監視する場合は "Monitor only selected accounts" を選択します。アカウント名を入力し、Addをクリックしてリストに追加します。エントリを選択して、Removeをクリックして削除します。

フィルタはセッションごとに適用されるため、コンピュータが複数のユーザーが同時にログインしているターミナル サーバー (TS、RDP) である場合にも正しく機能します。各セッションのアカウントは個別にフィルタに対してチェックされ、監視されていないアカウントは単にコンソールに表示されません。

クラウドからコンピュータを追加する

Cloud Connection タイプを使用してリモート コンピュータにエージェントをインストールした場合は、それらのコンピュータをコンソールに追加できるようになります。

Cloud accountを作成したことを確認してください。クラウド アカウントは、エージェントのインストール中、またはメニュー「Cloud / Create cloud account...」を使用して作成できます。

クラウドモニタリングを構成する

クラウド接続を使用したモニタリングの詳細については、ここをクリックしてください。

すでにCloud accountを作成している場合は、メニュー「Cloud / Configure cloud connection」を使用して、このクラウド アカウントのログイン情報をコンソールに入力できます。

クラウド経由のモニタリングを設定する

その後、メニュー「Cloud / Add computers from Cloud」を使用して、既にクラウドに追加されているコンピュータを追加できます。

クラウドからコンピュータを追加する場合、エージェントのパスワード (リモート コンピュータへのエージェントのインストールを使用して入力したパスワード) を入力する必要があります。

インストールされているエージェントのネットワークをスキャン

ネットワーク コンピュータのスキャン

リモート コンピュータにエージェントをすでにインストールしている場合は、ネットワークをスキャンしてエージェントを自動的に追加できます。スキャンでは、事前に接続タイプを選択する必要はありません。スキャンでは、すべてのアドレスに対して最初に TLS を試行し、アドレスが積極的に応答したが TLS を拒否した場合にのみエンドツーエンド暗号化に戻ります。そのため、いずれかのモードを使用しているエージェントは追加の構成なしで検出されます。

ネットワーク アダプタと IPv4 範囲を選択し、エージェントのパスワードとポートを入力して、[Scan] をクリックします。アクティブなスキャンを停止するには、[Stop] をクリックします。

FAQ: スキャン用のデフォルトのネットワーク アダプターを設定するにはどうすればよいですか?

File / Configuration... を開きます。 [General タブの Default network adapter で必要なアダプタを選択し、OK をクリックします。新しいScan network for computers... ダイアログごとに、このアダプタが選択されます。使用できない場合は、最初のアクティブなアダプターが選択されます。設定されたデフォルトを変更せずに、現在のスキャンに別のアダプターを選択できます。

結果には、ホスト名、IP アドレス、およびパスワードのステータスが表示されます。パスワードが正しい場合、OS には報告されたオペレーティング システムがアイコン付きで表示され、Agent version には報告されたエージェントのバージョンが表示されます。これらの詳細は、利用可能な場合にのみ表示されます。個別の OS バージョン列や不明な値のプレースホルダーはありません。

Show only computers not yet added はデフォルトでオフになっているため、検出されたすべてのコンピュータが表示されます。ホスト名または IP アドレスがすでにコンソールにあるコンピュータを非表示にするには、これをオンにします。再度表示するにはクリアします。

現在表示されている結果のチェックボックスを変更するには、Select all または Unselect all を使用します。個々の選択は、さらに多くの結果が到着するときやフィルターが変更されるときに保持されます。 Add では、チェックが入った、表示されているコンピュータのみを追加します。列は、最も幅の広いエントリに自動的に適合します。

コンピュータのPropertiesでは、OS アイコンが報告されたオペレーティング システム名のすぐ左側に表示されます。エージェントのバージョンは利用可能な場合に表示されます。古いエージェントが Windows 11 コンピュータ上で Windows 10 を報告した場合は、エージェントを更新し、再接続またはスキャンを再度行ってください。

LAN コンピュータのグループを追加

LAN 上のコンピュータを監視する

LAN 上にコンピュータを自動的に追加できます。 LAN で許可されている場合 (NT DOMAIN 管理者など)、エージェントをリモートでインストールできます。

[Show only computers not yet addedチェックボックスは、Add group of LAN computersでも使用できます。デフォルトではチェックされていません。すでにコンソールに追加されているコンピュータ名を非表示にするには、これをオンにします。

リモート コンピュータのリスト

リスト

Remote Computers Listには、追加されたすべてのコンピュータが表示されます。コンピュータ アイコンには、リモート コンピュータの状態が表示されます。

マウスの右クリックで呼び出せるObject Menuを使用して、いくつかのシステム コマンドに簡単にアクセスできます。

コンピュータはグループに編成できます。Fileメニューから「Add computer group...」を使用します。

コンピュータ グループを右クリックし、オブジェクト メニューから "Filter by this group on Remote Screens" を選択すると、Remote Screens タブがそのグループに即座にフィルタリングされます。これは同じフィルタです。 Remote Screens タブのグループ フィルタ ドロップダウンを使用して設定することもできます。

デフォルトでは、コンソールの起動時にすべてのコンピュータ グループが展開されます。これを変更するには、File メニューの General タブから「Configuration...」を使用し、「Expand groups when console starts」のチェックを外します。

同じ General タブには、[Automatically trust a computer's certificate the first time it connects over TLS 経由での初回接続時にコンピュータの証明書を自動的に信頼する" がデフォルトでオンになっています。新しいコンピュータの証明書を自動的に信頼するのではなく、承認のために保持するには、このチェックボックスをオフにします。上記のConnection securityを参照してください。

コンピュータのインポートとエクスポート (CSV、タブ区切り、Excel)

コンピュータとグループは、CSV、タブ区切りテキスト、または Microsoft Excel (.xlsx) ファイルに一括エクスポートして、インポートし直すことができます。 Fileメニューから"Export Computers to File..."と"Import Computers from File..."を選択するか、コンピュータグループ(またはすべてを含めるにはリストの空の領域)を右クリックし、Object Menuから同じコマンドを選択します。ファイルは UTF-8 として読み書きされます。

エクスポートする場合、[保存] ダイアログでファイルの種類を直接選択します: CSV (Comma delimited)、CSV (Semicolon delimited)、Tab Delimited Text、またはMicrosoft Excel。インポート時に、CSV またはタブ区切りファイルの区切り文字が自動的に検出されます。

エクスポートされたファイルでは、以下の列順序が使用されます。ヘッダー行が同じ列名を保持している限り、インポート時に列を並べ替えることができます。認識されない列は無視され、空のままの列では、以下に示すデフォルトが使用されます。host のみが必要です。

列説明空の場合のデフォルト
グループコンピュータのグループ パス。例: /研究室1/A室。欠落しているグループはインポート時に自動的に作成されます。ルート (/)
名前コンソールに表示される表示名(ニックネーム)。ホストにフォールバックします
ホストIP アドレスまたはホスト名。必須 - 行が空の場合はスキップされます
ポートエージェント接続ポート。デフォルトのエージェント ポート
パスワードエージェント接続パスワード。以下の注を参照 - 決してエクスポートされません
接続タイプダイレクト、リバース、クラウド、またはカンマ区切りの組み合わせ。直接
自動接続Yes または No - 起動時にコンソールが自動的に接続するかどうか。はい
マルチセッション自動、単一、または複数。自動
ハードエージェントのクラウド登録のハードウェア ID。クラウドエントリを自動接続するために必要です。以下の注を参照してください

password列はエクスポート時に常に空のままになります。パスワードがファイルに書き込まれることはありません。インポート時に、共通のパスワードを 1 回入力でき、パスワード列が空のすべての行に使用されます。独自のパスワード値を持つ行では、代わりにその値が使用されます。

connection_type にクラウドが含まれるコンピュータの場合、hwid も指定する必要があります。これはエージェントのクラウド登録を識別します。空のままにした場合は、インポートしたコンピュータのプロパティを開き、Use Cloud connectionを再度有効にして、クラウド アカウントから一致するコンピュータを選択し、再接続します。

従業員の監視を始める準備はできましたか?

このアプリケーションを今すぐ購入してください。自分の決断を決して後悔することはありません。

今すぐ購入